PDA

View Full Version : H2 Piezo high E cutting out



H2-DGT
10-26-2012, 11:29 PM
Hey guys
Out of nowhere my 20th anni H2's piezo started to cut out the volume on the high E string. You can still hear a signal, but barely. I changed the battery, tried different jack/toggle settings to no avail. Any ideas?
Thanks!

wood-n-wire
02-14-2013, 10:20 PM
Hey guys
Out of nowhere my 20th anni H2's piezo started to cut out the volume on the high E string. You can still hear a signal, but barely. I changed the battery, tried different jack/toggle settings to no avail. Any ideas?
Thanks!

I'm having the same problem with my HB II. I have tried different toggle settings, the mix/mag jack, Peizo jack and am getting only a very faint signal off the high E. When I tap on the Peizo with my pick all the other strings "pick-up" except for the high E. Any recommendations - ideas?
Many thanks

justmund
02-14-2013, 10:30 PM
The piezo bridge uses 6 individual "pickups", one for each string. Sounds like one of those has worked loose through vibration, I dare say it would be a fiddly fix.

Best thing is to shoot the PTC an email and book it in for repair.

http://www.prsguitars.com/ptc/

wood-n-wire
02-15-2013, 08:51 AM
Awesome - thanks for the advice!

markie
02-15-2013, 09:28 AM
The piezo bridge uses 6 individual "pickups", one for each string. Sounds like one of those has worked loose through vibration, I dare say it would be a fiddly fix.

Best thing is to shoot the PTC an email and book it in for repair.

http://www.prsguitars.com/ptc/





Exactly................................ I send an older (mid 90s) to the PTC for the very same thing. I believe Shawn replaced the the (one) Piezo P-up & sent it back to me. I have no idea about the cost of that P-up, as I had some other work done as well.