Results 1 to 3 of 3

Thread: Cavity buzz on SC HB1 with piezo

  1. #1
    Junior Member
    Join Date
    May 2012
    Posts
    2

    Cavity buzz on SC HB1 with piezo

    I have a SC HB1 with the piezo that I really like. However I'm having an intermittent vibration buzz coming from the electronics area in the body cavity. Applying pressure to the plate around the battery cover sometimes helps. I've removed the battery and unscrewed the plate to look inside but nothing appears to be loose. Has anyone run into this before? Any suggestions?

    It's only noticeable while playing unplugged but it's a little annoying since this is how I usually practice with the family around.

    Thanks!

  2. #2
    Bobble Head Moderator JMintzer's Avatar
    Join Date
    Apr 2012
    Location
    Potomac, MD
    Posts
    1,258
    Sometimes its the pup selector toggle switch. Stick your finger in the "f" hole (no, not that one!), and put pressure on the spring clips that surround the toggle. See if that solves the problem...


    Jamie

  3. #3
    Junior Member
    Join Date
    May 2012
    Posts
    2
    Quote Originally Posted by JMintzer View Post
    Sometimes its the pup selector toggle switch. Stick your finger in the "f" hole (no, not that one!), and put pressure on the spring clips that surround the toggle. See if that solves the problem...


    Jamie
    Thanks I'll try that next time it happens. It the switch is the problem do you have a suggestion on how to fix it permanently?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •