Results 1 to 13 of 13

Thread: 2 Channel H Noises???

  1. #1
    Junior Member
    Join Date
    Jan 2013
    Posts
    14

    Exclamation 2 Channel H Noises???

    I just got my 2 channel H combo amp this week after a long wait. I was disappointed in that there are a lot of strange noises eminating from both channels. I traced a bad reverb tube but the microphonics present when even tapping the top of the amp are really bad. Has anyone else experienced this? The shipper (Fedex) trashed the first one they sent me and this one took a beating too but I did make sure all the tubes were seated well.

    I can tap on the top and it was like a select switch for noise. It almost sounds like a radio coming through at times (it's definitely not) or just weirg fizzy crackling noises. The clean channel seems worse. There is also a feedback (high pitch) noise and it sounds exactly like it but my guitar is off. It comes and goes, on it's own or when tapping the top.

    I hope it is a quick fix. I spoke to someone at PRS and they are sending a couple of preamp tubes but I was wondering if anyone else has experienced this or has a suggestion. Also how quiet are your amps?

    This is a return for me to amp distorion from class a with stomp box, which is dead quiet.

    Thanks!

    PSJ

  2. #2
    Sounds like a microphonic tube, nothing to worry about.

  3. #3
    Junior Member
    Join Date
    Jan 2013
    Posts
    14
    Quote Originally Posted by LSchefman View Post
    Sounds like a microphonic tube, nothing to worry about.
    that is what I thought but they all make a noise when I touch them after I replaced the one suspect. I guess I am just making sure nobody else is having an issue and that they are generally noise free amps.

  4. #4
    Senior Member Dirty Bob's Avatar
    Join Date
    Apr 2012
    Location
    State of Confusion (NY)
    Posts
    1,711
    I agree it sounds like microphonics to me too...maybe just bad luck in relation to the tubes...let us know how it goes after the retube!
    -Bob

  5. #5
    Quote Originally Posted by PSJ1026 View Post
    that is what I thought but they all make a noise when I touch them after I replaced the one suspect. I guess I am just making sure nobody else is having an issue and that they are generally noise free amps.
    My HXDA is the quietest amp I've ever owned, including several Two-Rocks, which are well known to be very quiet amps.

  6. #6
    Angry Southern Gentleman Hopeful Sinner's Avatar
    Join Date
    Apr 2012
    Location
    Alabama
    Posts
    1,382
    My "H" is pretty quiet... No weird noises to speak of...
    -Jon

    "I'm a sinner and I hope I never change"

  7. #7
    Junior Member
    Join Date
    Jan 2013
    Posts
    14

    Amp died on 1st set

    Well the amp lost volume and then died altogether after only 5-6 songs. No lights and an really bad smell of burnt electronics. Not a happy camper after waiting over 3 months for a replacement when Fedex dropped the first one. Not sure if I should give up and stick with my trusty Dr Z amps. Sound guy commented on the PRS after sound check and said it sounded great. At the end of the night he took it back and said the Dr Z blew it away.

  8. #8
    Can't comment on the comparison between the two amps, as good tone is a subjective thing, but you know that PRS will take care of you. I'd call customer service Monday morning and make arrangements with them to have it looked at and repaired.

    Things happen, especially in shipping. It's inconvenient and frustrating to have an amp fail for any reason. No doubt!

    BTW, Zaite makes a great amp! They definitely have their own thing going on.

  9. #9
    Senior Member MA Pete's Avatar
    Join Date
    Apr 2012
    Posts
    365
    No noises like you describe for me.

    I do find the gain channel to be a bit noisy at gig volumes, but I think it has been due to ground loop issues...
    Ted Club President

  10. #10
    Junior Member
    Join Date
    Jan 2013
    Posts
    14
    Quote Originally Posted by LSchefman View Post
    Can't comment on the comparison between the two amps, as good tone is a subjective thing, but you know that PRS will take care of you. I'd call customer service Monday morning and make arrangements with them to have it looked at and repaired.

    Things happen, especially in shipping. It's inconvenient and frustrating to have an amp fail for any reason. No doubt!

    BTW, Zaite makes a great amp! They definitely have their own thing going on.
    They are taking care of me and I DO NOT blame PRS. I think FedEx beats the crap out of everything they touch. The amps are packed well but they decided to ship with the tubes installed for some reason. The clearly want a great relationship with their customers and while I am disappointed as long as I have a good working amp soon I will be happy. Even not at 100 percent it sounded good. My Dr Z amps are different and I am used to them so I didn't put too much into the sound guys comment. From what I heard his ears were not entirely trustworthy.

  11. #11
    Junior Member
    Join Date
    Jan 2013
    Posts
    14
    BTW thanks for all the replies. I know these guys stand behind their product and even though Doug has been making amps for years there is going to inevidibly be some tweaking needed. I am sure it will be worth it. I usually get comments on my sound and I think I have pretty good ears for tone. It's there and going back to 6L6 tubes will be great for me.

  12. #12
    Member The Ratchet's Avatar
    Join Date
    Apr 2012
    Location
    Theatre Near You
    Posts
    123
    Quote Originally Posted by PSJ1026 View Post
    Well the amp lost volume and then died altogether after only 5-6 songs. No lights and an really bad smell of burnt electronics. Not a happy camper after waiting over 3 months for a replacement when Fedex dropped the first one. Not sure if I should give up and stick with my trusty Dr Z amps. Sound guy commented on the PRS after sound check and said it sounded great. At the end of the night he took it back and said the Dr Z blew it away.
    I played brand new MESA in a GC once that had just been taken out of the box and literally caught on fire and smoke came out of it. So it can happen to any tube amp and who knows where / when the issue crept in. Could be FedEx droppin it too many times though.

  13. #13
    Junior Member
    Join Date
    Apr 2012
    Posts
    16

    Smile

    Quote Originally Posted by PSJ1026 View Post
    Well the amp lost volume and then died altogether after only 5-6 songs. No lights and an really bad smell of burnt electronics. Not a happy camper ....
    The same thing happened with my PRS "30" combo after 6 months of enjoying its glorious tones. All of a sudden it began to make a frying bacon sound and then it just died and heavy smoke came out and stunk up the room. I shipped it back to Guitar Rez in Austin, that's where I had bought it, and the amp tech told me "it had just blown its brains out", meaning some resistors had fried themselves. He thought this was odd because the parts are way over-engineered for the circuit and the amp didn't blow a fuse. Anyway, PRS sent him the needed parts to replace and fix my amp and it came back, but, somehow the tone was a little different. I'm still debating whether it's just my ears or whether in fact the tone changed a little bit. I still like it though. Also, after a short time of it being back from being repaired it began to hum/buzz a little bit. Before the amp "blew its brains out" it had been dead quite. I replaced the preamp JJ tubes with the same, but, the hum continued to appear suddenly. Finally, I sent it back a second time and this time the amp tech had to staple a sheet of copper to the inside of the wooden case over the chassis. It makes a grounded shield and hum/buzz gets minimized. But it is still not as dead quiet as when I originally bought it. It's still one of my favorite amps, even though the hum/buzz somewhat bothers me between songs because I knew that before all of this, it use to be dead quiet on idle! OP, I hope your H combo gets completely fixed to its full glory.
    Last edited by el chuco; 01-26-2013 at 01:55 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •