Results 1 to 9 of 9

Thread: Problems with Archon amp....again

  1. #1
    Junior Member
    Join Date
    May 2014
    Posts
    18

    Exclamation Problems with Archon amp....again

    Guys, I received my Archon today, I was so excited to finally play it...But bummer!

    I have a pretty loud hum all over the two channels (pretty disturbing when playing on reasonable volume levels) and when I play on the clean channel I hear the distorted guitar tone in the background...Even when I turn the channel volume completely down I can hear the distorted channel on the clean channel...There is also some serious hiss going on when I turn the depth knob. I ordered the Archon because of his brilliant clean channel but with that amount of noise in the background, there is no real "clean".

    This is already my second Archon, the first only had the hum problem. I really do not know what's happening here.

    I tried everything: Different guitars, 100w/50w, effect loop on and off, different rooms...Nothing...I even moved the amp to another house...

    Could you describe the noise you get with your Archon if you have any? The Archon has already been sent back to the dealer...:-( Again!

  2. #2
    SuperD Boogie's Avatar
    Join Date
    Apr 2012
    Location
    Indy, IN
    Posts
    1,322
    It's time to take your amp to the dealer and have them use different guitars, cables, power, etc. Hand it to someone else to see if you have an environmental issue or other hardware problems...remove those factors from the equation. The chances of having two identically damaged amps is pretty slim. Regardless, I'm confident that the issue will be resolved.
    + '01 Custom 24 + '11 DGT Standard (Mr. Clean) + '09 SE One + Super Dallas + Stealth 2x12+

  3. #3
    A♥ hoards guitars A♥ rugerpc's Avatar
    Join Date
    Jun 2012
    Location
    deep in the raspberry...
    Posts
    3,416
    I think Boogie has it right.

    Until you switch out everything in the signal chain, including the power source, you cannot be sure it is the Archon itself.

    It could even be appliances in your house. Older refrigerators, air conditioners, heaters, florescent lights, halogen lights, dimmers. Crap! There are SO many outside sources of unwanted signal! Dimmers are a particularly nasty source.

    Before I threw in the towel, I'd try someone else's house guitars and cables with it. If you can duplicate the unwanted sounds at the dealer with their guitars and cables, then it may be time for another swap...

    edit - don't forget the cable from the head to the cab....
    Last edited by rugerpc; 05-13-2014 at 08:21 AM.
    Thbbbbbt...
    Check it out: Phillybri used to have a band: Resonance But he's soooo over them now!
    Lexicon
    ísɹǝqɯǝɯ uɐıןɐɹʇsnɐ oןןǝɥ

  4. #4
    Senior Member wardog's Avatar
    Join Date
    Mar 2013
    Location
    Canton, MI
    Posts
    545
    i am no expert, but do you experience this interference on other electronics in the area? I only ask due to the fact the amp will amplify electrical interference from other sources, like florescent lights, PC monitors, hell your watch can be heard thru the pickups if you place it to close. Again, no expert.
    I like surprises!!!

  5. #5
    Senior Member
    Join Date
    Apr 2012
    Posts
    369
    Hey...what country are you in? The US version is 110 only if I'm not mistaken (even though the fuse is labed 3A at 250).

  6. #6
    Junior Member
    Join Date
    May 2014
    Posts
    18
    Guys, I tried everything...Different cables, different guitars, different rooms....Nothing did help. The first Archon with the hum problem only was send back to the dealer and they told me they can not hear anything unnormal. But the second Archon that I sent back was analyzed and indeed those problems where diagnosed. So I do not know what the problem with the first one at my house was, but the second one really had some problems.

    I am in Germany and the amp is made for German current and 250, so all is good.

    Do your Archons do have any hum when you switch the amp from standby to full power?

    I really do not know where the hum should come from because all of my other amps in this room work perfectly fine with the same cables.

  7. #7
    Senior Member
    Join Date
    Apr 2012
    Posts
    369
    Well, that's a bummer. What you are describing sounds like you just got two bad amps. My Archon has absolutely no hum at all, in either standby or on....lead or clean channel. The amp is really high gain of course, so if you have the lead channel dimed you'll likely get noise at any reasonable volume (when you're not actually playing the guitar) but that would be more of a hiss than a hum. From your original description though, it sounds like you're getting the hum in either channel, regardless of the channel volume settings.

    Regarding the dealer telling you that the first one sounded fine to them...in my experience, depending on the dealer, you often get the story that "they all do that". I hope this doesn't sour you to the Archon. Who knows what was going on with those two amps, but when you finally do end up getting a good one, you'll love it.

  8. #8
    Junior Member
    Join Date
    Sep 2012
    Posts
    28
    I had this same issue recently with 2 EVH 5153's back to back, Finally Fender just gave me a refund. They first time the power tubes took a dive on me. The 2nd was the output transform and power tubes. If it's happening across all the channels regardless of volume, and even with nothing plugged in, it's the amps power section. It may be tubes, transformer, or anything there. Get a hold of Matt King at PRS via customer service email.

  9. #9
    Junior Member
    Join Date
    May 2014
    Posts
    18
    Quote Originally Posted by aristotle View Post
    From your original description though, it sounds like you're getting the hum in either channel, regardless of the channel volume settings.
    Yeah, on all channels and even without a guitar plugged in...Pretty loud actually. I mean When you are standing in front of the amp you have to speak up to be louder than the hum...Not a pleasure to play the amp...Crossing fingers for the third Archon.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •